Inoperative turn signals

If it's mechanical, electrical or just downright confusing, this is the place to find and share answers.
Post Reply
kbailey
Registered Member
Posts: 10
Joined: 24 Nov 2018, 09:10

Inoperative turn signals

#1

Post by kbailey » 19 Jun 2019, 12:26

Ok, 1970 Eliminator, fixed steering column. I have brake and running lights, all corners. When I use the turn signal, (engine running) the turn signal indicator lights up in the dash, but the turn signals in the rear go blank. If hitting the brakes and using the turn signal (either direction) the brake lights work correctly, but the side with the turn signal activated on it, goes blank. No sequencer, not solid, nothing. Ideas?? Thanks!!! Kenny

User avatar
Blitz
Supporting Member
Supporting Member
Posts: 1310
Joined: 08 Nov 2011, 13:02
Location: Salem, OR

Re: Inoperative turn signals

#2

Post by Blitz » 19 Jun 2019, 16:44

Here's a good starting place: http://www.thuntek.net/cougars_unlimited/69seqts.htm

The most likely culprits are the turn signal switch or the sequential unit in the trunk. Here are links to replacements:

Turn signal switch

Solid state sequential unit (for standard incandescent bulbs)
-Andrew Chenovick
Photo/Video guy for WEST COAST CLASSIC COUGAR, INC.
Side Gig: FLYING A PHOTOGRAPHY


RIDES:
-1968 Mercury Cougar: original family owned, Polar White, 289-2V, auto, AC / "Snowball" view project thread
-1973 Opel Manta: 1.9L, 5-speed (restored)
-1991 Mazda Miata: fun driver
-1992 Volvo 240 wagon: classy hauling machine

Post Reply